File format "MED" not available

All questions about installation
Forum rules
Please read the forum usage recommendations before posting.
Post Reply
Veribum
Posts: 2
Joined: Sun Jul 24, 2022 12:34 pm

File format "MED" not available

Post by Veribum »

Hi everybody, I have problems with my first simulation in CS.
I set up all parameters but simulation can't start and in the preprocessor.log this message appears:

.------------------------------.
| |
| Code_Saturne Preprocessor |
| |
`------------------------------'

code_saturne version 7.0.4-patch (built Wed Aug 10 16:38:23 2022)

CGNS 3.4.0 file format support
Reading of compressed files ('.gz') with Zlib 1.2.11


Error in preprocessor execution
===============================

ecs_pre.c:486: Fatal error.

File format "MED" support not available in this
installation (file "/home/pov/simple_junction/MESH/downcomer.med").


Call stack
1: 0x56418ad5a3a7 <ecs_pre__type_format+0x3e7> (cs_preprocess)
2: 0x56418ad55261 <ecs_cmd__lit_arg+0x321> (cs_preprocess)
3: 0x56418ad52f7d <main+0x4d> (cs_preprocess)
4: 0x7f476af73083 <__libc_start_main+0xf3> (libc.so.6)
5: 0x56418ad537ce <_start+0x2e> (cs_preprocess)
End of stack




There is a problem with MED package installation, I thought. So I tried to re-install it manually but another issue occurs:

pov@com:~/Scrivania/code_saturne.build_build/med-4.0.0$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... no
checking for mawk... mawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking whether UID '1001' is supported by ustar format... yes
checking whether GID '1001' is supported by ustar format... yes
checking how to create a ustar tar archive... gnutar
configure: Trying /usr/ home path for searching H5pubconf.h file.
configure: Trying /usr//lib/x86_64-linux-gnu/hdf5/serial/ home path for searching H5pubconf.h file.
checking for a sed that does not truncate output... /bin/sed
checking whether to compile C using MPI... no
checking for style of include used by make... GNU
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc understands -c and -o together... yes
checking dependency style of gcc... gcc3
checking for gcc option to accept ISO C99... none needed
checking whether to compile FC using MPI... no
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
configure: HDF version is not a parallel one.
checking for grep that handles long lines and -e... /bin/grep
checking how to run the C preprocessor... gcc -E
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking absolute name of <H5public.h>... checking H5public.h usability... yes
checking H5public.h presence... yes
checking for H5public.h... yes
///usr//lib/x86_64-linux-gnu/hdf5/serial//include/H5public.h
checking absolute name of <H5Ipublic.h>... checking H5Ipublic.h usability... yes
checking H5Ipublic.h presence... yes
checking for H5Ipublic.h... yes
///usr//lib/x86_64-linux-gnu/hdf5/serial//include/H5Ipublic.h
checking for H5open in -lhdf5... yes
checking for h5dump... no
configure: error: Can't find h5dump, please verify your env. var. PATH or use of --with-hdf5bin=<binpath>.


I tried to launch the command:
./configure --with-hdf5bin=path of the bin directory
but it doesn't work.
How can I fix this issues?

Thanks.
Yvan Fournier
Posts: 4107
Joined: Mon Feb 20, 2012 3:25 pm

Re: File format "MED" not available

Post by Yvan Fournier »

Hello,

I recommend trying the newer MED 4.1 instead of MED 4.0 (to reduce the risk of compatibility issues with meshes generated by the latest SALOME versions).

When building MED, i usually provide the whole HDF5 path, using '--with-hdf5' rather than just hdf5bin,

But if you a running on a Debian-basd system, you may simply be missing the hdf5-tools package (I'm not sure how the packages are split or named in Red-Hat or SUSE type distributions). Can you try installing that ?

Also, be careful if you have a very recent (or rolling) distribution using HDF5 1.12. MED requires HDF5 1.10, so in this case, you would need to install an older version also.

Best regards,

Yvan
Post Reply