Problems with Qt5

All questions about installation
Forum rules
Please read the forum usage recommendations before posting.
Post Reply
Joseph-Cousteau
Posts: 1
Joined: Thu Mar 07, 2024 1:55 pm

Problems with Qt5

Post by Joseph-Cousteau »

Good morning!
I tried in vain today to use code saturne; it worked great, but days ago i installed (and then removed) spyder5 by pip.
since then, I started to have issues with PyQt5 and Qt5 :(
After typing the command

Code: Select all

code_saturne gui
in the terminal, this appeared:

Code: Select all

user@my_laptop:~$ code_saturne gui
Cannot mix incompatible Qt library (5.15.2) with this library (5.15.3)
Aborted (core dumped)
I am using Code Saturne 8.03 on Xubuntu 22.04 LTS
How can i fix it?
Yvan Fournier
Posts: 4107
Joined: Mon Feb 20, 2012 3:25 pm

Re: Problems with Qt5

Post by Yvan Fournier »

Hello,

The error message explains it all.

If you follow the recommendations on the Wiki here (https://github.com/code-saturne/code_sa ... n-packages), you do not need to use pip to install PyQt.

Only use pip if you understand its behavior well enough : unless you force the version number, a reinstall may install a more recent version.
If that happens, you simply need to reinstall code_saturne so as to relink-it with the correct version.

This can also occur using standard packages on a rolling Linux release, such as Arch. But in that case it should not come as a surprise, as developers using rolling releases usually expect this to occur occasionally so are not surprised.

Best regards,

Yvan
Post Reply