Orthotropic Conduction

This forum is dedicated to Syrthes related issues, as the Syrthes tool does not have its own forum.
Post Reply
meredithalex
Posts: 2
Joined: Fri Apr 14, 2023 1:55 pm

Orthotropic Conduction

Post by meredithalex »

Hello,

I am trying to run a code_saturne/syrthes coupled case (there are two solid domains) with orthotropic conduction, such that I can reduce the conduction in the axial direction (specifically in a fuel pin).
I first tried this using "syr_user_cond" with some if statements for the axial heights which apply to the change, however, this was failing during the setting of initial conditions. I thought this may be something to do with how I programmed it, however, I have since tried "CPHY_MAT_ORTHO_3D" with all x, y and z conductivity's at the same value and it fails at the same point. The base case with isotropic material properties runs ok, with the only difference between the two, the pin properties (all other files are exactly the same):

CPHY_MAT_ORTHO_3D= 10000.0 300.0 3.0 3.0 3.0 6 32 42 52 62 72

CPHY_MAT_ISO= 10000.0 300.0 3.0 6 32 42 52 62 72

Perhaps there are some known issues with orthotropic conduction or it should only be used for certain applications? For information, I have pasted the error messages below from the solid and fluid listing and also the "output" file in the top directory.

Thanks,

Alex

Solid Domain

==========================================================================================
SETTING INITIAL CONDITIONS
==========================
[compute-0-0:249356] *** Process received signal ***
[compute-0-0:249356] Signal: Segmentation fault (11)
[compute-0-0:249356] Signal code: Address not mapped (1)
[compute-0-0:249356] Failing at address: 0x2b9795835010
[compute-0-0:249356] [ 0] /lib64/libpthread.so.0(+0xf5e0)[0x2b967a8955e0]
[compute-0-0:249356] [ 1] ./syrthes[0x404d8c]
[compute-0-0:249356] [ 2] ./syrthes[0x410da8]
[compute-0-0:249356] [ 3] ./syrthes[0x404c80]
[compute-0-0:249356] [ 4] /lib64/libc.so.6(__libc_start_main+0xf5)[0x2b967aac3c05]
[compute-0-0:249356] [ 5] ./syrthes[0x404679]
[compute-0-0:249356] *** End of error message ***

Fluid Domain

SIGTERM signal (termination) received.
--> computation interrupted by environment.

Call stack:
1: 0x2ad5b8322270 <+0x35270> (libc.so.6)
2: 0x2ad5b8b0f20a <+0x14e20a> (libopen-pal.so.20)
3: 0x2ad5b89fd2c9 <opal_progress+0xb9> (libopen-pal.so.20)
4: 0x2ad5b7b21c3d <ompi_request_default_wait+0x1d> (libmpi.so.20)
5: 0x2ad5b7b4c10c <PMPI_Sendrecv+0x27c> (libmpi.so.20)
6: 0x2ad5b56a2d04 <+0x7d04> (libple.so.2)
7: 0x2ad5b56a5a53 <ple_locator_exchange_point_var+0x142> (libple.so.2)
8: 0x41409b <cs_syr4_coupling_recv_tsolid+0x546> (cs_solver)
9: 0x417e43 <cs_syr_coupling_exchange_volume+0x3c3> (cs_solver)
10: 0x2ad5b3a98e62 <condli_+0x1fa1> (libsaturne-7.0.so)
11: 0x2ad5b3d65f84 <tridim_+0x7265> (libsaturne-7.0.so)
12: 0x47d7d8 <caltri_+0x3c08> (cs_solver)
13: 0x2ad5b3742bff <+0x4bff> (libcs_solver-7.0.so)
14: 0x2ad5b3742edd <main+0x139> (libcs_solver-7.0.so)
15: 0x2ad5b830ec05 <__libc_start_main+0xf5> (libc.so.6)
16: 0x410c09 <> (cs_solver)
End of stack

Output


solid2
--------------------------------------------------------------------------
MPI_ABORT was invoked on rank 0 in communicator MPI COMMUNICATOR 3 SPLIT FROM 0
with errorcode 1.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.
--------------------------------------------------------------------------
--------------------------------------------------------------------------
mpiexec noticed that process rank 0 with PID 0 on node compute-0-0 exited on signal 11 (Segmentation fault).
--------------------------------------------------------------------------
Post-calculation operations
---------------------------

Post-calculation operations
---------------------------

Post-calculation operations
Yvan Fournier
Posts: 4107
Joined: Mon Feb 20, 2012 3:25 pm

Re: Orthotropic Conduction

Post by Yvan Fournier »

Hello,

I suspect an error when computing the exchange coefficient for coupling in the orthotropic case (which is probably not expected/tested), but to confirm this and check how to fix this would require either reviewing that part of the code, or running it under a debugger (ideally with Valgrind) to really check this.

Did you try contacting Syrthes support ?

Best regards,

Yvan
Post Reply