Syrthès installation issue with med

This forum is dedicated to Syrthes related issues, as the Syrthes tool does not have its own forum.
Post Reply
Rodolphe
Posts: 14
Joined: Sun Mar 14, 2021 12:59 pm

Syrthès installation issue with med

Post by Rodolphe »

Hi,

I'm trying to do the coupling between Code Saturne and Syrthès with the tuto uploaded years ago on this forum (viewtopic.php?p=7724#p7724). But when I try to install Syrthès first, I have an error with med library :

checking consistency of all components of python development environment... no
configure: error: in `/home/rodolphe/S4.3/syrthes-linux-4.3.0/syrthes4.3.0/extern-libraries/src/TMP/med-3.0.7.build/Linux_x86_64':
configure: error:
Could not link test program to Python. Maybe the main Python library has been
installed in some non-standard library path. If so, pass it to configure,
via the LDFLAGS environment variable.
Example: ./configure LDFLAGS="-L/usr/non-standard-path/python/lib"
============================================================================
ERROR!
You probably have to install the development version of the Python package
for your distribution. The exact name of this package varies among them.
============================================================================

See `config.log' for more details
make: *** Aucune règle pour fabriquer la cible « install ». Arrêt.
Error during make install of med-3.0.7


Note that i had an issue with the python path when installing CS few months ago and i had to do alias python/export python in the .bashrc file to make it work.

I'm running on Ubuntu 20.04 LTS.

Sorry, I did not find the config.log file (I'm new on Linux).

Best regards,


Rodolphe Vancoillie
Yvan Fournier
Posts: 3371
Joined: Mon Feb 20, 2012 3:25 pm

Re: Syrthès installation issue with med

Post by Yvan Fournier »

Hello,

You seem to have downloaded the old release of Syrthes and not the one available on this website (https://www.code-saturne.org/cms/download/prerequisites). That version includes obsolete precompiled binaries, so when searching for posts on this forum, you will have more luck with recent posts than very old tutorials.

Best regards,

Yvan
Rodolphe
Posts: 14
Joined: Sun Mar 14, 2021 12:59 pm

Re: Syrthès installation issue with med

Post by Rodolphe »

Hello,

Thanks a lot for your quick answer. I did download the latest version of Syrthès as you advised but nevertheless I still have some issues. I join the setup and error files.

Thanks for your help !

Rodolphe
Attachments
setup.ini
(4.03 KiB) Downloaded 16 times
ERREUR.log
(2.22 KiB) Downloaded 19 times
Yvan Fournier
Posts: 3371
Joined: Mon Feb 20, 2012 3:25 pm

Re: Syrthès installation issue with med

Post by Yvan Fournier »

Hello,

Are you sure there are *.h files under /home/rodolphe/Salome/SALOME-9.5.0/BINARIES-CO7/hdf5/include ? This seems to be a "salome-platform.org" binary SALOME installation, and I do not remember if headers are included or not.

Best regards,

Yvan
Rodolphe
Posts: 14
Joined: Sun Mar 14, 2021 12:59 pm

Re: Syrthès installation issue with med

Post by Rodolphe »

Hello,

Yes there are .h files in /home/rodolphe/Salome/SALOME-9.5.0/BINARIES-CO7/hdf5/include.
I also tried with hdf5 that I've downloaded from Code Saturne prerequisites (which worked when I've installed Code Saturne) but I still have errors. Here are the error and setup files with also the syrthescfd.log file since the error file seems to point out this file.

Thanks,

Best regards,

Rodolphe
Attachments
setup.ini
(4.01 KiB) Downloaded 19 times
ERREUR.log
(2.98 KiB) Downloaded 17 times
syrthescfd.log
(1.71 KiB) Downloaded 17 times
Yvan Fournier
Posts: 3371
Joined: Mon Feb 20, 2012 3:25 pm

Re: Syrthès installation issue with med

Post by Yvan Fournier »

Hello,

If the libraries work with code_saturne, it means it is probably the Syrthes installer which does not pass the correct compile or link options.

I am not very familiar with the Syrthes install scripts (or rather, each time I need to solve an issue with them, I basically need to restart from 0), so simply letting those scripts install another version of HDF5 and MED might be the the fastest solution.

Best regards,

Yvan
niuniuaba
Posts: 6
Joined: Mon May 17, 2021 10:22 am

Re: Syrthès installation issue with med

Post by niuniuaba »

It seems there is a 'dedicated' syrthes site online now https://www.syrthes-software.org/
After downloading ver. 5.0 and taking a look at the 'VERSION.md' file (which is not included in ver 4.3.5), as far as I understand, syrthes 4.3.5 is NOT compatible with med-4.1.0. If you want it with med-4.1.0 you can try syrthes 5.0.

Best regards,

niuniuaba
Yvan Fournier
Posts: 3371
Joined: Mon Feb 20, 2012 3:25 pm

Re: Syrthès installation issue with med

Post by Yvan Fournier »

Hello,

Actually, I would be surprised if you cannot compile Syrthes 4.3 with MED 4.1, though it was tested and released with older versions.

So I believe the issue is different. In any case, the new Syrthes version should also be compatible with code_saturne, but it's installer contains some binary files, which may work better on some systems than others.

So you can try both ans see what works best.

Best regards,

Yvan
niuniuaba
Posts: 6
Joined: Mon May 17, 2021 10:22 am

Re: Syrthès installation issue with med

Post by niuniuaba »

I would be surprised if you cannot compile Syrthes 4.3 with MED 4.1
Sorry I confused this thread with another one viewtopic.php?f=11&t=2794.
Back to this one, I think the issue is that hdf5 and med are from different 'pairs'. For example if you use hdf5 from CO7 binaries package it's a better idea to use med from the same package.

Code: Select all

hdf5  USE=yes  PATH=/home/rodolphe/Salome/SALOME-9.5.0/BINARIES-CO7/hdf5
med   USE=yes  PATH=/home/rodolphe/Salome/SALOME-9.5.0/BINARIES-CO7/medfile
Another thing I noticed is the path of ple.

Code: Select all

ple USE=yes    PATH=/home/rodolphe/CS6.0/code_saturne-6.0.6(1)/code_saturne-6.0.6/libple
should be

Code: Select all

ple USE=yes    PATH=/home/rodolphe/CS6.0/code_saturne-6.0.6(1)/code_saturne-6.0.6
isn't it?
Yvan Fournier
Posts: 3371
Joined: Mon Feb 20, 2012 3:25 pm

Re: Syrthès installation issue with med

Post by Yvan Fournier »

Hello,

Yes, you should use the same HDF5 that MED was built with, so using the 2 from the same package is the most reliable way to do this.

And for PLE, yes, the path should match the top-level directory, not one of its subdirectories, and when PLE is built along with code_saturne, it's installation path is the same as for all of code_saturne. So the second version seems right.

Best regards,

Yvan
Post Reply