Build error: syrthescfd

This forum is dedicated to Syrthes related issues, as the Syrthes tool does not have its own forum.
Post Reply
tpa
Posts: 49
Joined: Fri Mar 16, 2012 11:35 pm

Build error: syrthescfd

Post by tpa »

In my efforts to perform a conjugate heat transfer with code_saturne I now realise that the build process was incomplete.

The syrthescfd related log (the full error log is attached) is:

Code: Select all

make: *** [syrthescfd] Error 2
../pp.log:       printf("\n ERROR : No coupled fluid 1d element \n",i+1);
../pp.log:       printf("\n ERROR : Entries given in the data file and entries found in the mesh don't match \n",i+1);
../syrthescfd.log:syr_cfd_coupling.c:1885:52: error: ‘PLE_COUPLING_TS_FOLLOWER’ undeclared (first use in this function)
../syrthescfd.log:make[1]: *** [syr_cfd_coupling.o] Error 1
../syrthescfd.log:make: *** [syrthescfd] Error 2
and the problem seems to be declaration of ‘PLE_COUPLING_TS_FOLLOWER’.
As I don't know much about programming and the code is complex not obvious to me how to solve this but I hope that someone with more insight will take a look at the attached error log and point me in the right direction.

All other seems to work - also when I install against hdf5/med/scotch libraries of the version of Salome that I use and was also used for building code_saturne.

Presently I have built against the ple of code_saturne 7.0.6 and the external libraries supplied with the package.

Code: Select all

 ple USE=yes   PATH=/opt/code_saturne-7.0.6/arch/Linux_x86_64
ERREUR.log
(8.37 KiB) Downloaded 261 times
The full log from the build of syrthescfd is also attached:
syrthescfd.log
(74.84 KiB) Downloaded 264 times
I will appreciate any help I can get :-)
Yvan Fournier
Posts: 4102
Joined: Mon Feb 20, 2012 3:25 pm

Re: Build error: syrthescfd

Post by Yvan Fournier »

Hello,

I assume you are using Syrthes 5.0.

An additional time synchronization option "follower mode" was added in code_saturne 8.0 and Syrthes 5, but was not merged into code_saturne 7.0.6.

I guess we could merge this safely into the next code_saturne 7.0.7 release, but in the meantime, if you want to use code_saturne 7.0.6 with a recent Syrthes version, one solution is to build and install a separate PLE from the Git repository version (https://github.com/code-saturne/libple), and install code_saturne 7.0 using the "--with-ple=<path>" configuration option to use that same version.

Actually, given the way PLE versions its algorithms and options, if you use that PLE install only for Syrthes, things should work in theory (though I have not tested that combination). And if you install code_saturne 8.0, you could in the same manner use that install's PLE for Syrthes, and keep code_saturne 7.0 's own PLE...

A final option is to use Syrthes 4.

And if your computation domain is mostly fluid, with a bit of solid, using code_saturne's built-in conjugate heat transfer is an even better and simpler option (if you have mostly solid cells, it will work fine also, but be computationally more expensive).

Best regards,

Yvan
tpa
Posts: 49
Joined: Fri Mar 16, 2012 11:35 pm

Re: Build error: syrthescfd

Post by tpa »

Thank you very much Yvan. This seems to explain it. I may start with seeing if Saturne 8 will work with the version of MED and HDF5 of my Salome. If not I will build them with new libraries as I am not dependant of compatibility with Salome as I dont use the Salome module anyway.
Post Reply