Syrthes 5.0 / CS7.0 installation

This forum is dedicated to Syrthes related issues, as the Syrthes tool does not have its own forum.
ansystk
Posts: 9
Joined: Thu Jun 10, 2021 12:53 pm

Syrthes 5.0 / CS7.0 installation

Post by ansystk »

Hi all,

I am facing some troubles to compile Syrthes 5.0 from source and to link it to the Saturne code 7.0.0.

The installation from source of the Saturne code is ok as I could compute some CFD simulations without any issues.

I am on ubuntu 20.04 LTS.

I tried also the 4.3.5 Syrthes version and to compile with the "ple USE=no and syrthescfd INSTALL=no" options to make a standalone Syrthes install without any success.

I attach below my setup.ini and the error.log files

Thank you in advance for your help,
Best regards,
David
Attachments
setup.ini
(4.18 KiB) Downloaded 386 times
ERREUR.log
(8.84 KiB) Downloaded 371 times
Yvan Fournier
Posts: 4102
Joined: Mon Feb 20, 2012 3:25 pm

Re: Syrthes 5.0 / CS7.0 installation

Post by Yvan Fournier »

Hello,

The Syrthes installer's ERROR.log generation simply seems to "grep" "error" in all logs, which is a rotten way of reporting errors, since it reports possible error messages in source files...

the only actual error there is

"collect2: error: ld returned 1 exit status"
../pp.log:make[1]: *** [Makefile:24 : a.out] Erreur 1
../pp.log:make: *** [Makefile:49 : pp] Erreur 2

So some other library is missing. But I am not sure which. You might try to add "-lz" to the specific_lib option in setup.ini, in case it is the one (I suggest this because I had a similar issue recently, and seem to rememeber this was the missing lib).

Best regards,

Yvan
ansystk
Posts: 9
Joined: Thu Jun 10, 2021 12:53 pm

Re: Syrthes 5.0 / CS7.0 installation

Post by ansystk »

Hello Yvan,

As suggested, I tried to compile the code by adding the following line in the setup.ini:
specific_lib= -L /usr/lib/x86_64-linux-gnu/liblz4.so.1.9.2

The error log is the same.

In the terminal, the installation script stops at the library: libicui18n.so.52 which is installed from the repository but in version 66. Might be a compatibility problem but no success with specific_lib= -L /usr/lib/x86_64-linux-gnu/libcui18n.so.66

Any idea on how to locate the problematic library? I am not an expert in code compiling.

Thank you,
Best regards,
David
Yvan Fournier
Posts: 4102
Joined: Mon Feb 20, 2012 3:25 pm

Re: Syrthes 5.0 / CS7.0 installation

Post by Yvan Fournier »

Hello,

Sorry, I did not mean "liblz", but libz. So "-lz" is sufficient, in addition to the previous option. Otherwise, you might have an error message relative to the exact library in the compile output in the terminal, or in one of the log files such as pp.log (in the directory above the one with the install script).

Best regards,

Yvan
ansystk
Posts: 9
Joined: Thu Jun 10, 2021 12:53 pm

Re: Syrthes 5.0 / CS7.0 installation

Post by ansystk »

Hello Yvan,

I tried again no success. I delete everything and try to compile again with clean sources and with the default settings. I checked all the log files I could find in the repositories you mentionned. They all terminate with the mention: "make[1] : on quitte le répertoire ..."

Please find attached a screenshot of the terminal.

Thank you,
Best regards,
David
Attachments
ERREUR.log
(4.52 KiB) Downloaded 362 times
Capture d’écran du 2021-06-30 09-25-51.png
Yvan Fournier
Posts: 4102
Joined: Mon Feb 20, 2012 3:25 pm

Re: Syrthes 5.0 / CS7.0 installation

Post by Yvan Fournier »

Hello,

Does the install still fail ? The messages seem Ok here.

Best regards,

Yvan
ansystk
Posts: 9
Joined: Thu Jun 10, 2021 12:53 pm

Re: Syrthes 5.0 / CS7.0 installation

Post by ansystk »

Hello Yvan,

The install still fails. In the shell I have a warning indicating that the installation of some components failed. I found an error in the pp.log. Something with the scoth library. I have attached the log file.

Thank you,
Best regards,
David
Attachments
setup.ini
(4.22 KiB) Downloaded 374 times
pp.log
(94.16 KiB) Downloaded 381 times
Yvan Fournier
Posts: 4102
Joined: Mon Feb 20, 2012 3:25 pm

Re: Syrthes 5.0 / CS7.0 installation

Post by Yvan Fournier »

Hello,

Yes, this is what I suspected.

Can you try adding :

specific_lib= -lz

To your setup.ini ?

Regards,

Yvan
ansystk
Posts: 9
Joined: Thu Jun 10, 2021 12:53 pm

Re: Syrthes 5.0 / CS7.0 installation

Post by ansystk »

Yvan,

I've just tried. The error still occurs.

Regards,
David
Attachments
setup.ini
(4.24 KiB) Downloaded 375 times
pp.log
(94.16 KiB) Downloaded 378 times
ERREUR.log
(4.77 KiB) Downloaded 356 times
Yvan Fournier
Posts: 4102
Joined: Mon Feb 20, 2012 3:25 pm

Re: Syrthes 5.0 / CS7.0 installation

Post by Yvan Fournier »

Hello,

It seems that "-lz" is not added correctly by that part of the script. You would need to modify the Makefiles at a lower level to fix this (I have needed to do similar things in the past, but do not remember the details ; I'll check if I have a trace but do not guarantee it).

Best regards,

Yvan
Post Reply