configure: error: cannot find PyQt5 Installation Windows 10

All questions about installation
Forum rules
Please read the forum usage recommendations before posting.
Post Reply
marilou
Posts: 1
Joined: Mon Jul 20, 2020 5:32 pm

configure: error: cannot find PyQt5 Installation Windows 10

Post by marilou » Mon Jul 20, 2020 5:50 pm

Hi,

I am trying to install code saturne 6.0.0, on Windows 10. I use MinGW msys.

$PYTHONPATH=C:/Anaconda
$MEDPATH= C:/Users/s1897502/med-4.0.0.tar/med-4.0.0
$HDF5PATH= C:/Users/s1897502/hdf5/hdf5-1.12.0

$cd C:/Users/s1897502/saturne/code_saturne/codesaturne
$./configure --prefix=C:/Users/s1897502/saturne/saturne_build/dbg\ --with-hdf5=HDF5PATH --with-PyQt5=PYTHONPATH\ --with-med=MEDPATH\


I have the following error :

configure: error: cannot find PyQt5 support (>= 5.0) or PyQt4 support (>= 4.5), Graphical User Interface cannot be installed

Please find attached the config log.

I am using Python with Anaconda and this seems to be the problem but I don't know how to solve it.
(PyQt5 is saved in C:\Anaconda\sip\PyQt5 )


Thanks in advance for your help.

Marilou
Attachments
config.log
(153.71 KiB) Downloaded 26 times

Yvan Fournier
Posts: 3049
Joined: Mon Feb 20, 2012 3:25 pm

Re: configure: error: cannot find PyQt5 Installation Windows 10

Post by Yvan Fournier » Tue Jul 21, 2020 5:40 pm

Hello,

I recommend you read the beginning of the installation manual:

- Builds in the source tree are not supported; you should use a separate build directory.
- There is no -with-PyQt5= option. You need to edit the PYTHONPATH instead
- for MED adn HDF5, are HDF5PATH and MEDPATH environment variables ? I would assume they start wih a special character ($ or maybe % on Windows)

- Also, how did you install MED and CGNS ? We stopped building on MinGW (aybe another variant) because HDF5 was not supported anymore on it, and its build failed (it was supported on native Windows, native Linux, and maybe Cygwin, but not MINGW). Also, unless you patch it (and I am not sure it is a good idea), MED 4.x requires HDF5 1.10, not 1.12.

Regards,

Yvan

Post Reply