Error with PyQt5

All questions about installation
Forum rules
Please read the forum usage recommendations before posting.
Yvan Fournier
Posts: 3424
Joined: Mon Feb 20, 2012 3:25 pm

Re: Error with PyQt5

Post by Yvan Fournier »

Hello,

What type of system/distribution are you running under the WSL ? The Python libraries are in /usr/lib most of the time, but I have never seen a system with the Python executabl in /usr/lib.

What does the "type python3" command return ?

Regards,

Yvan
bmehra
Posts: 4
Joined: Thu Oct 01, 2020 3:07 pm

Re: Error with PyQt5

Post by bmehra »

Thanks,

Its ubuntu 20.04 and "type python3" returns "python3 is hashed (/usr/bin/python3)"

Regards

Bineet
Yvan Fournier
Posts: 3424
Joined: Mon Feb 20, 2012 3:25 pm

Re: Error with PyQt5

Post by Yvan Fournier »

Hello,

so that is the value you need to define as python (in the automatic installer) or PYTHON= (in the lower-level "configure" options).

Things should then work. Do you have additional Python environments (such as CONDA) ? They can make a mess if you mix versions.

Best regards,

Yvan
Post Reply