[SOLVED] Problems with import MED mesh

All questions about installation
Forum rules
Please read the forum usage recommendations before posting.
Post Reply
RobertSawko
Posts: 2
Joined: Fri Apr 01, 2016 6:03 pm

[SOLVED] Problems with import MED mesh

Post by RobertSawko » Fri Apr 01, 2016 6:13 pm

Hello,

I am completely new to Code Saturne and I am just trying out the cavity tutorial which I know worked out of the box for my colleagues. I believe I followed the guidelines correctly, but of course can't be 100% sure. My problem is that Code Saturne doesn't accept my Salome mesh and complains with the following error:

Code: Select all

MEDversionedApi3C.c [50] : Cette bibliothèque MED n'est pas capable de lire un fichier MED dont le mineur de la versionexcède celui de la bibliothèque.
MEDversionedApi3C.c [51] : La version demandée est :
MEDversionedApi3C.c [51] : _fversionMMR = 310
MEDversionedApi3C.c [116] : Impossible d'obtenir une implémentation de : 
MEDversionedApi3C.c [117] : key = "_MEDmeshInfoByName"
MEDversionedApi3C.c [118] : en version :
MEDversionedApi3C.c [119] : _fversionMMR = 310
MEDversionedApi3C.c [120] : Vérifiez votre fichier .med
MEDmeshInfo.c [83] : Erreur d'appel de l'API 
MEDmeshInfo.c [83] : du maillage 
MEDmeshInfo.c [84] : meshname = "Cavity_mesh"
MEDmeshInfo.c [84] : _meshpath = "/ENS_MAA/Cavity_mesh"
MEDmeshInfo.c [84] : "MEDmeshInfoByName" = "MEDmeshInfoByName"

Error in preprocessor execution
===============================

../../../code_saturne-4.0.4/preprocessor/pre-post/ecs_pre_med.c:1624: Fatal error.

MED: error reading file "/home/robert/documents/sandbox/code_saturne-tutorials/shear_driven_cavity/MESH/Cavity_mesh.med".
Name of mesh read : "Cavity_mesh"
Dimension read : "0"


Call stack 
1: 0x42a382 (cs_preprocess)
2: 0x40f09b (cs_preprocess)
3: 0x406692 (cs_preprocess)
4: 0x7ffa89daeec5 (libc.so.6)
5: 0x406efa (cs_preprocess)
End of stack
I understand that the error is about exceeding a minor version of the MED file. I have checked it and indeed my Salome saves to 3.1 MED file whereas the MED library on my Ubuntu is 3.0.6. I've tried two Salomes already, the universally statically linked and the Ubuntu one. I've also checked that exporting to STL correctly visualised in paraview. C_S is compiled in version 4.0.4 as latest stable. Writing this up, I realized I may compile a development version too, so I'll give it a go presently, but this should suffer from the same problem.

I would like to ask if this is a known issue or if I am doing something wrong with the tutorial after all. Please let me know.

RobertSawko
Posts: 2
Joined: Fri Apr 01, 2016 6:03 pm

Re: [SOLVED] Problems with import MED mesh

Post by RobertSawko » Sun Apr 03, 2016 1:20 pm

I have now confirmed that the problem is due to MED library. After compiling MED 3.1 from Salome website and linking my Saturne compilation against it the mesh imports correctly. I will get back to this problem and try to create a PPA for Ubuntu perhaps as this could be useful to new users, perhaps?

Yvan Fournier
Posts: 2689
Joined: Mon Feb 20, 2012 3:25 pm

Re: [SOLVED] Problems with import MED mesh

Post by Yvan Fournier » Sun Apr 03, 2016 8:13 pm

Hello,

Yes, this problem is known, and is mostly a build/packaging issue (the code can build either with MED 3.0 or 3.1).

We should release 4.0.5 this week, and will set MED to 3.1 in the automatic installer, but this won't change anything for prepackaged distributions, where every distribution may need to upgrade, and this may be against the package version upgrade policy of stable versions of some distributions, in which case building your own is the best policy (having our own repository would be even better, but this requires extra resources and time).

Regards,

Yvan

elen_am
Posts: 4
Joined: Sun Sep 09, 2018 8:35 am

Re: [SOLVED] Problems with import MED mesh

Post by elen_am » Thu Sep 13, 2018 8:35 am

I have a similar error. To create the grid used Salome in 8_5_0. Code-Saturn version 5.0.8. What version of Code-Saturn is needed?

Yvan Fournier
Posts: 2689
Joined: Mon Feb 20, 2012 3:25 pm

Re: [SOLVED] Problems with import MED mesh

Post by Yvan Fournier » Thu Sep 13, 2018 8:40 am

Hello,

Version 5.0.8 will work fine if you build it with MED 3.3.

It is the MED library version linked to the code which is important here.

Best regards,

elen_am
Posts: 4
Joined: Sun Sep 09, 2018 8:35 am

Re: [SOLVED] Problems with import MED mesh

Post by elen_am » Thu Sep 13, 2018 1:27 pm

I export med file of version 3.3, but in the log file it writes that version 3.0. What could be the problem?

Image

Image

Yvan Fournier
Posts: 2689
Joined: Mon Feb 20, 2012 3:25 pm

Re: [SOLVED] Problems with import MED mesh

Post by Yvan Fournier » Thu Sep 13, 2018 5:03 pm

Hello,

Could you be more specific ? System, installation method, which tool to export, whose log ?

Regards,,

Yvan

elen_am
Posts: 4
Joined: Sun Sep 09, 2018 8:35 am

Re: [SOLVED] Problems with import MED mesh

Post by elen_am » Mon Sep 17, 2018 7:42 am

hello,
my operating system is Ubuntu 64 bit, installed Code Saturne from this site, downloaded the file, unpacked. Version 5.0. Also tried version 4.0. The effect is the same. To export the file, Salome version 8.5.0 was used. log file of Code Saturne.

Yvan Fournier
Posts: 2689
Joined: Mon Feb 20, 2012 3:25 pm

Re: [SOLVED] Problems with import MED mesh

Post by Yvan Fournier » Mon Sep 17, 2018 9:08 am

Hello,

This is still not specific enough. You do not even specify the Ubuntu version. Please check the forum usage recommendations for a list of details to provide.

Regards,

Yvan

Post Reply