Installation C_S v4.0

All questions about installation
Forum rules
Please read the forum usage recommendations before posting.
sante
Posts: 41
Joined: Thu May 14, 2015 1:09 am

Re: Installation C_S v4.0

Post by sante » Mon Jun 22, 2015 4:05 pm

hi it's me again . I meant the winrar file intaller of C_D - 4.0.1?

clalgourdin
Posts: 20
Joined: Tue Apr 28, 2015 9:42 am

Re: Installation C_S v4.0

Post by clalgourdin » Mon Jun 22, 2015 4:24 pm

Hello Yvan,

Thanks a lot for your help, Now I can open Code_Saturne,

I will work with Salome for the pre-processing, so I try to run the tutorial "Pipe",

I export from Salome the file : "pipe.med"

In code saturne, in the section "Calculation environment" I check the mesh but I have this error :

"Error while loading shared librairies : libple.so.O: cannot open shared object file : No such file or directory"

I have already seen this error in an other topic in this forum :

http://code-saturne.org/forum/viewtopic ... bple#p8808

So, I have made the command : sudo ldconfig (and restart my PC) without success.

Do you have any idea ? (for information I don't work with Syrthes)

Regards

Claude


For Sante,
I hope, Yvan can confirm my words, the setup file was created, when you run for the first time the file "code_saturne.py" in the directory separated of the source code.
Attachments
check mesh.pdf
(27.88 KiB) Downloaded 207 times

Yvan Fournier
Posts: 2719
Joined: Mon Feb 20, 2012 3:25 pm

Re: Installation C_S v4.0

Post by Yvan Fournier » Tue Jun 23, 2015 12:52 am

Hello,

What files are present in your:

/home/halton/Code_Saturne/4.0.0/code_saturne-4.0.0/arch/Linux_x86_64/lib

directory ? What is your "configure" command (at the top of your "confi.log file) ?

I have already encountered this issue, though it is not always reproducible.

Did you/could you try installing from a clean (empty) build directory ?

Regards,

Yvan

clalgourdin
Posts: 20
Joined: Tue Apr 28, 2015 9:42 am

Re: Installation C_S v4.0

Post by clalgourdin » Tue Jun 23, 2015 9:29 am

Hello Yvan,

In the directory : /home/halton/Code_Saturne/4.0.0/code_saturne-4.0.0/arch/Linux_x86_64/lib :

- 8 files :
- libple.la
- libple.so
- libple.so.1
- libple.so.1.0.0
- libsaturne.la
- libsaturne.so
- libsaturne.so.0
- libsaturne.so.0.0.0

- 2 directories :
- code_saturne (empty)
- python2.7

For the file config.log, I have 2 files in my build directory (I don't know if it's normal).

N°1 : /home/halton/Bureau/code_saturne/C_S_4.build/config.log

This is the configure in the "first" file config.log :

$ /home/halton/Bureau/code_saturne/C_S_4/configure --prefix=/home/halton/Code_Saturne/4.0.0/code_saturne-4.0.0/arch/Linux_x86_64 --with-cgns=/usr --without-metis --without-scotch PYTHON=/usr/bin/python --enable-french --disable-static CC=/usr/bin/mpicc FC=/usr/bin/f95



N°2 : /home/halton/Bureau/code_saturne/C_S_4.build/libple.log/config.log

This the configure in the "second" file config.log :

$ /home/halton/Bureau/code_saturne/C_S_4/libple/configure --disable-option-checking --prefix=/home/halton/Code_Saturne/4.0.0/code_saturne-4.0.0/arch/Linux_x86_64 --with-cgns=/usr --without-metis --without-scotch PYTHON=/usr/bin/python --enable-french --disable-static CC=/usr/bin/mpicc FC=/usr/bin/f95 --cache-file=/dev/null --srcdir=/home/halton/Bureau/code_saturne/C_S_4/libple

concerning your sentence :
"Did you/could you try installing from a clean (empty) build directory ?"

I think but I'm not totally sure !

In : /home/halton/Bureau/code_saturne/
I have the build directory (C_S_4.build) but also others directories ...

Regards

Claude

Yvan Fournier
Posts: 2719
Joined: Mon Feb 20, 2012 3:25 pm

Re: Installation C_S v4.0

Post by Yvan Fournier » Tue Jun 23, 2015 2:34 pm

Hello,

Things seem OK, but I would recommend starting from a clean build, meaning:

"running the configure script or automatic installer inside a previously empty directory"

(if you did many tests in the same directory, it is not empty, and might have conflicting traces of previous tests).

Regards,

Yvan

clalgourdin
Posts: 20
Joined: Tue Apr 28, 2015 9:42 am

Re: Installation C_S v4.0

Post by clalgourdin » Tue Jun 23, 2015 5:41 pm

Hello Yvan,

Good job ! I have re-run the automatic installer in a clean directory and no error appear !


Thank you sincerely

Regards,

Claude

sante
Posts: 41
Joined: Thu May 14, 2015 1:09 am

Re: Installation C_S v4.0

Post by sante » Mon Jun 29, 2015 4:51 pm

hello Clalgourdin ,
please you can give me the complete procedure to install C_S - 4.0.1 ? whether the attachment file
Thank you .

Yvan Fournier
Posts: 2719
Joined: Mon Feb 20, 2012 3:25 pm

Re: Installation C_S v4.0

Post by Yvan Fournier » Wed Jul 01, 2015 12:17 am

Hello,

This forum is useful fo feeback and recommendations for specific cases, but for the whole procedure, I remind you we have an installation manual on this web site: http://code-saturne.org/cms/sites/defau ... ll-4.0.pdf. We may also improve this documentation based on your feedback and suggestions.

Regards,

Yvan

sante
Posts: 41
Joined: Thu May 14, 2015 1:09 am

Re: Installation C_S v4.0

Post by sante » Sat Aug 29, 2015 1:50 pm

Hello
I Code_Saturne - 3.0.1 installed. I would like to install 4.0.2 - C_S automatically but I did not manage to execute install_saturne.py .
please help me
Best regards

Yvan Fournier
Posts: 2719
Joined: Mon Feb 20, 2012 3:25 pm

Re: Installation C_S v4.0

Post by Yvan Fournier » Sun Aug 30, 2015 8:41 pm

Hello,

Could you provide more details, as described in the forum recommendations ?

Regards,

Yvan

Post Reply