[SOLVED] Issues installing CGNS with install script (6.0)

All questions about installation
Forum rules
Please read the forum usage recommendations before posting.
Post Reply
sampg
Posts: 4
Joined: Fri Nov 29, 2019 3:50 pm

[SOLVED] Issues installing CGNS with install script (6.0)

Post by sampg » Fri Nov 29, 2019 4:11 pm

Hi,

I am having some trouble installing with the python install script for the 6.0.0 version. I am trying to install with all components, but I get an error when installing cgns. I am getting an error which suggests that I do not have a recent enough version of hdf5, even though the latest version was just installed by the script.

I have attached relevant log files.

Thanks in advance,
Sam
Attachments
setup_ini.txt
(4.06 KiB) Downloaded 2 times
install_saturne.log
(545.27 KiB) Downloaded 3 times
console_log.txt
(2.98 KiB) Downloaded 3 times
Last edited by sampg on Mon Dec 09, 2019 5:05 pm, edited 1 time in total.

Yvan Fournier
Posts: 2791
Joined: Mon Feb 20, 2012 3:25 pm

Re: Issues installing CGNS with install script (6.0)

Post by Yvan Fournier » Sun Dec 01, 2019 2:25 am

Hello,

Your config.log contains:

Code: Select all

-- HDF5 C libs:0 static: and shared:
-- Found HDF5: /share/apps/code_saturne/Code_Saturne/6.0.0/hdf5-1.10.5/arch/Linux_x86_64/lib/libhdf5.so;/usr/lib64/libz.so;/usr/lib64/libdl.so;/usr/lib64/libm.so  
-- HDF5- found: INC=/share/apps/code_saturne/Code_Saturne/6.0.0/hdf5-1.10.5/arch/Linux_x86_64/include TOOLS=/share/apps/code_saturne/Code_Saturne/6.0.0/hdf5-1.10.5/arch/Linux_x86_64/lib/../bin HDF5_BUILD_SHARED_LIBS=0
-- HDF5 link libs: /share/apps/code_saturne/Code_Saturne/6.0.0/hdf5-1.10.5/arch/Linux_x86_64/lib/libhdf5.so;/usr/lib64/libz.so;/usr/lib64/libdl.so;/usr/lib64/libm.so
CMake Error at CMakeLists.txt:293 (message):
  HDF5 version must be greater than 1.8.0
So it seems the error is in the CGNS Cmake HDF5 detection, which does not choose the correct HDF5 even when it should. I'll check if we can also add a default hdf5 headers (INCLUDE) path, which might help (with GNU Autotools, which have other advantages and disadvantages, a default structure is implied, which avoid needing this sort of messy addition, and is one of the reasons we stick to autotools and do not migrate to CMake, but this is halfway off-topic).

You probably have a packagedd hdf5 1.8 version in /usr/lib; If you have the possibility of removing it (i.e. if you do not need it for some other software), the code_saturne build may work.

You forgot to provide the recommended information, so I cannot say whether this is a good solution or not.

Regards,

Yvan

sampg
Posts: 4
Joined: Fri Nov 29, 2019 3:50 pm

Re: Issues installing CGNS with install script (6.0)

Post by sampg » Mon Dec 02, 2019 10:03 am

Hi Yvan,

Thanks for this info. There seem to be a few hdf5 tools in /usr/bin which are all at 1.8.12. The system is a cluster based on the Rocks distribution and the old hdf5 version must have come with the distribution. Ideally I would like to avoid removing the old version.

Thanks,
Sam

Yvan Fournier
Posts: 2791
Joined: Mon Feb 20, 2012 3:25 pm

Re: Issues installing CGNS with install script (6.0)

Post by Yvan Fournier » Mon Dec 02, 2019 2:33 pm

Hello,

Could you post the /share/apps/code_saturne/saturne_build/CGNS-3.4.0.build/CMakeFiles/CMakeOutput.log file mentioned in install_saturne.log ?

Otherwise, perhaps you can try to install CGNS "manually", using "ccmake -i" in /share/apps/code_saturne/saturne_build/CGNS-3.4.0.build to try to check/set additional CMake options relative to hdf5 and replace parts possibly under /usr/lib wit the paths to the newly installed 1.10 version, but I am not 100% certain this will work.

CGNS can also be installed using ./"configure" in its src subdirectory if I remember correctly, but I have not tested that "legacy" option recently.

Best regards,

Yvan

sampg
Posts: 4
Joined: Fri Nov 29, 2019 3:50 pm

Re: Issues installing CGNS with install script (6.0)

Post by sampg » Mon Dec 02, 2019 2:59 pm

I've attached the logs. I will take a look at installing manually and see where I get with it, although I am a little unfamiliar with CMake.

Thank you for your help so far,
Sam
Attachments
CMakeOutput.log
(17.01 KiB) Downloaded 3 times

Yvan Fournier
Posts: 2791
Joined: Mon Feb 20, 2012 3:25 pm

Re: Issues installing CGNS with install script (6.0)

Post by Yvan Fournier » Wed Dec 04, 2019 1:56 pm

Hello,

The log does not provide any additional info that I know how to use.

The issue might be due to "too old" CMake version on the cluster. I am not sure, but I have both encountered cases where a too old verson of CMake would lead to an error message and others where there was not error message but things did not work correctly, so that could be an explaination.

In this case, you my "cd" to the CGNS-3.4.0/src source directory, and use ./configure from there (check ./configure --help for options) to install CGNS.

Best regards,

Yvan

sampg
Posts: 4
Joined: Fri Nov 29, 2019 3:50 pm

Re: Issues installing CGNS with install script (6.0)

Post by sampg » Mon Dec 09, 2019 5:04 pm

Yvan Fournier wrote:
Wed Dec 04, 2019 1:56 pm
Hello,

The log does not provide any additional info that I know how to use.

The issue might be due to "too old" CMake version on the cluster. I am not sure, but I have both encountered cases where a too old verson of CMake would lead to an error message and others where there was not error message but things did not work correctly, so that could be an explaination.

In this case, you my "cd" to the CGNS-3.4.0/src source directory, and use ./configure from there (check ./configure --help for options) to install CGNS.

Best regards,

Yvan
I think the Cmake version was the issue. I was previously using CMake 2.8.12.2. Updating to 3.16.0 fixed the issue.

Thank you for your help.
Sam

Post Reply