Issues to coupling with SALOME-MECA 2018

All questions about installation
Forum rules
Please read the forum usage recommendations before posting.
Post Reply
zanelatoeb
Posts: 2
Joined: Thu Apr 11, 2019 7:41 pm

Issues to coupling with SALOME-MECA 2018

Post by zanelatoeb » Thu Apr 25, 2019 3:21 pm

Dear,

I already have Salome-Meca 2018 installed on my PC. So that I don't have to install SALOME again (via Salome-Plataform or Salome-CFD), I would just like to couple the Code-Saturne (CFDSTUDY) package to Salome-Meca.
However, I'm not able to couple the packages.

I tried the two installation modes:
1) install_saturne.py -> setup (with installation ID with salome and path "/home/erick/salome_meca/V2018.0.1_public").
2) configure (also with the same folder ID with salome above) -> make -> make install.

The logs for case 1 is below. For case 2, after run "make install" it seems that nothing occurs, no logs or errors messages. Then I run Salome-Meca and CFDSTUDY isn't there.

I don't found anything about this error or make install trouble.

If you can help me, I will be immensely grateful.

The computer is a Dell XPS 15, NVIDIA video card, Ubuntu 18.04 LTS.

Thanks,
Erick.
Attachments
install_saturne.log
(1.69 MiB) Downloaded 4 times

Yvan Fournier
Posts: 2611
Joined: Mon Feb 20, 2012 3:25 pm

Re: Issues to coupling with SALOME-MECA 2018

Post by Yvan Fournier » Fri Apr 26, 2019 12:41 am

Hello,

When installing Code_Saturne with an existing Salome installation, the Salome installation itself is not modified, so it is "normal" that CFDSTUDY does not appear under Salome-Meca. I am not sure about how the build for Salome-CFD works. We should post the YAMM (EDF build system for Salome) build scripts for Ubuntu on the website (though they may need to be adapted; the main YAMM configuration targets Debian 9), but this would not include code_aster, so would not solve your problem.

If you run "code_saturne salome", you should see CFDSTUDY in the Salome application which is launched.

I have not tested the code_aster coupling with Salome_Meca 2018 yet (I have checked it a few months ago with Salome_Meca 2017, and had it working, provided an up-to-date test case was used; in case of difficulty I can post that setup.

Regards,

Yvan

Post Reply