MEDCoupling support

Questions and remarks about code_saturne usage
Forum rules
Please read the forum usage recommendations before posting.
Post Reply
ffan
Posts: 66
Joined: Thu Jul 24, 2014 3:23 pm

MEDCoupling support

Post by ffan » Sun Oct 16, 2016 1:27 am

Hi,

I hope to build Code_Saturne 4.0.6 with SALOME-MECA-2016-LGPL-1. However, it did not successfully complete the build.

The install_saturne.log file says:
configure: WARNING: no MEDCoupling support
configure: error: in `/home/fafan/packages/Code_saturne-4.0.6_openmpi/code_saturne-4.0.6_openmpi.build':
configure: error: MEDCoupling support is requested, but test for MEDCoupling failed!
See `config.log' for more details

And, the config.log file says:
| #include <MEDCouplingUMesh.hxx>
| int
| main ()
| {
| using namespace ParaMEDMEM;
| MEDCouplingUMesh *m = MEDCouplingUMesh::New();
| ;
| return 0;
| }
|
configure:26113: WARNING: no MEDCoupling support
configure:26178: error: in `/home/fafan/packages/Code_saturne-4.0.6_openmpi/code_saturne-4.0.6_openmpi.build':
configure:26180: error: MEDCoupling support is requested, but test for MEDCoupling failed!
See `config.log' for more details

If Salome is not requested in the build, then it can finish building successfully. (Looks like it does not require MEDCoupling in this case.)

My complete install_saturne.log and config.log file are attached here. Please help how this problem can be resolved. Thank you.

- ffan
Attachments
config.log.gz
(65.96 KiB) Downloaded 97 times
install_saturne.log.gz
(2.53 KiB) Downloaded 92 times

Yvan Fournier
Posts: 3049
Joined: Mon Feb 20, 2012 3:25 pm

Re: MEDCoupling support

Post by Yvan Fournier » Sun Oct 16, 2016 7:00 pm

Hello,

This should be in the "installation" forum.

You can solve this issue by adding --disable-salome-med to your configure command (MEDCoupling is only used for some experimental features, not by standard features of the code).

Regards,

Yvan

ffan
Posts: 66
Joined: Thu Jul 24, 2014 3:23 pm

Re: MEDCoupling support

Post by ffan » Sun Oct 16, 2016 9:29 pm

Hi Yvan,

Thank you for reply. I am sorry. It is possible to move it to Installation forum now?

I added " --disable-salome-med" to installation.py, and it was indluded in the following configure command. But, the build still looked for MEDCoupling support and failed. The new config.log and install_saturne.log are attached. Thanks.

$ /home/fafan/packages/Code_saturne-4.0.6_openmpi/code_saturne-4.0.6_openmpi/configure --prefix=/home/fafan/Code_Saturne/4.0.6_openmpi/code_saturne-4.0.6/arch/Linux_x86_64 --with-hdf5=/home/fafan/Code_Saturne/4.0.6_openmpi/hdf5-1.8.16/arch/Linux_x86_64 --with-cgns=/home/fafan/Code_Saturne/4.0.6_openmpi/cgnslib-3.2.1/arch/Linux_x86_64 --with-med=/home/fafan/Code_Saturne/4.0.6_openmpi/med-3.1.0/arch/Linux_x86_64 --with-metis=/home/fafan/Code_Saturne/4.0.6_openmpi/parmetis-4.0.3/arch/Linux_x86_64 --with-scotch=/home/fafan/Code_Saturne/4.0.6_openmpi/scotch-6.0.4/arch/Linux_x86_64 PYTHON=/usr/bin/python --with-salome=/home/fafan/opt/SALOME-MECA-2016-LGPL-1/V2016 --disable-salome-med --disable-static CXX=/home/fafan/Code_Saturne/4.0.6_openmpi/openmpi-1.10.2/arch/Linux_x86_64/bin/mpicxx CC=/home/fafan/Code_Saturne/4.0.6_openmpi/openmpi-1.10.2/arch/Linux_x86_64/bin/mpicc FC=/usr/bin/f95


- ffan
Attachments
install_saturne.log.gz
(2.53 KiB) Downloaded 98 times
config.log.gz
(65.96 KiB) Downloaded 88 times

Yvan Fournier
Posts: 3049
Joined: Mon Feb 20, 2012 3:25 pm

Re: MEDCoupling support

Post by Yvan Fournier » Sun Oct 16, 2016 11:16 pm

Hello,

Sorry, I might have misspelled the option. Could you try "--without-salome-med" instead ?

Regards,

Yvan

ffan
Posts: 66
Joined: Thu Jul 24, 2014 3:23 pm

Re: MEDCoupling support

Post by ffan » Mon Oct 17, 2016 12:16 am

Good. It built. Thank Yvan.
However, when I tried the same on v4.3.1, it did not work. The build still looked for MEDCoupling.

- ffan

Yvan Fournier
Posts: 3049
Joined: Mon Feb 20, 2012 3:25 pm

Re: MEDCoupling support

Post by Yvan Fournier » Mon Oct 17, 2016 1:36 am

Hello,

Yes, starting with version 4.3.1, we switched to the more logical "--with-medcoupling=" / "--without-medcoupling" syntax.

So --without-medcoupling should work.

Regards,

Yvan

ffan
Posts: 66
Joined: Thu Jul 24, 2014 3:23 pm

Re: MEDCoupling support

Post by ffan » Mon Oct 17, 2016 3:28 am

Thank Yvan.

- ffan

ffan
Posts: 66
Joined: Thu Jul 24, 2014 3:23 pm

Re: MEDCoupling support

Post by ffan » Tue Oct 18, 2016 2:44 am

Hi Yvan,

I launched Code_Saturne with Salome by the command,
code_saturne salome

It said:
Environment variable VISU_ROOT_DIR must be set
Module VISU will be not available

In this installation, I used SALOME-MECA-2016-LGPL-1. Is VISU_ROOT_DIR=SALOME-MECA-2016-LGPL-1/V2016/modules/PARAVIS_V7_8_0_SMECA? The ParaVis module? Thanks.

- ffan

Yvan Fournier
Posts: 3049
Joined: Mon Feb 20, 2012 3:25 pm

Re: MEDCoupling support

Post by Yvan Fournier » Tue Oct 18, 2016 6:08 pm

Hello,

Does SALOME start or fail ? This might be only a warning relative to a tool prior to PARAVIS.

Regards,

Yvan

ffan
Posts: 66
Joined: Thu Jul 24, 2014 3:23 pm

Re: MEDCoupling support

Post by ffan » Tue Oct 18, 2016 8:53 pm

Thank Yvan. Salome started regardless VISU_ROOT_DIR is set or not. But, I don't know if anything related to visualization is missing if this environmental variable is not given.

- ffan

Post Reply