Faillure when partitioning mesh with more body than CPU

This forum is dedicated to Syrthes related issues, as the Syrthes tool does not have its own forum.
Post Reply
JonasA
Posts: 18
Joined: Tue Feb 06, 2018 11:49 am

Faillure when partitioning mesh with more body than CPU

Post by JonasA » Fri Mar 30, 2018 3:29 pm

Dear all,

Thanks to the Syrthes team for the code, I have used Syrthes 4.3 for the past few weeks and it is very fast and powerful.
I had an error when trying to run a case with more than one hundred bodies, the preprocessor function syrthes-pp call scotch or metis to do the partition (both gives the same result) and then crash with a segmentation fault when trying

Code: Select all

 if (!(p->suivant))  /* le noeud n'appartient qu'a 1 seule part */
ligne 259 of pp_cree_tables.c after having done many iteration of the loops (from fast debugging by outputting stuff to the log).
I have tried different mesh (gmsh and netgen from Salome) for the same geometry.
The last log output before the segfault is
*** CREE_TABLES_PARALL : creation of temporary tables for parallel execution
Elements number per partition :
- Partition 0 : 513933
- Partition 1 : 514106
- Partition 2 : 508252
- Partition 3 : 515982
- Partition 4 : 511368
- Partition 5 : 509011
- Partition 6 : 511722
- Partition 7 : 511787
- Partition 8 : 513892
- Partition 9 : 511538
- Partition 10 : 514106
- Partition 11 : 512832
- Partition 12 : 510913
- Partition 13 : 507989
- Partition 14 : 515242
- Partition 15 : 517624
- Partition 16 : 516295
- Partition 17 : 518181
- Partition 18 : 509486
- Partition 19 : 518130
Maximun number of elements per partition : 518181
The function syrthes-pp was working before that. I think that the error comes from that there is much more bodies in my case than in the previous simulation.
Could someone transmit to the Syrthes developers or tell me how to do the bug report?

Kinds regards
Jonas

Yvan Fournier
Posts: 2678
Joined: Mon Feb 20, 2012 3:25 pm

Re: Faillure when partitioning mesh with more body than CPU

Post by Yvan Fournier » Wed Apr 04, 2018 1:15 am

Hello,

I'll suggest to the Syrthes developers to take a look at this. There is no formal support system of bug-tracker for Syrthes.

Could you test this on a "debug build" (i.e. build with specifig_debug uncommented in setup.ini), ideally running it under Valgrind if the case is not too large ? That would help pinpoint the issue.

Regards,

Yvan

JonasA
Posts: 18
Joined: Tue Feb 06, 2018 11:49 am

Re: Faillure when partitioning mesh with more body than CPU

Post by JonasA » Wed Apr 11, 2018 3:45 pm

Thank you
I have done what you said and sent a mail to the Syrthes team. The fault is mine. I had a body meshed two times in my conduction mesh that were causing the preprocessing to crash.
So the error was that some nodes were belonging to multiple parts. I should have guessed it after the debugging.

Regards,
Jonas

Post Reply