syrthes refuses to run due to not-installed MPI

This forum is dedicated to Syrthes related issues, as the Syrthes tool does not have its own forum.
Post Reply
kathi
Posts: 13
Joined: Tue Nov 04, 2014 11:04 am

syrthes refuses to run due to not-installed MPI

Post by kathi » Wed Feb 08, 2017 1:08 pm

Bonjour,

when trying to run syrthes (from syrthes GUI) the GUI shows this error:

"""
SYRTHES4 home directory: /home/johannes/work/17_Kn_1/cas_3disks3d
-> Error !
Cannot find a MPI librairy.

Error during checking and loading environment.
Stop Syrthes execution.
"""

I have installed syrthes version 4.3, downloaded from here:
https://www.edf.fr/en/the-edf-group/wor ... ciel=10818

I attach the setup.ini which shows the type of installation which I did. I did not install MPI because I want to do only "non-parallel runs". Shouldn't that be possible?

I attach also the data input file of the syrthes run which causes this error.

Can me somebody please help? Thank you very much

kathi

setup.ini
(4.43 KiB) Downloaded 123 times
best regards

kathi

kathi
Posts: 13
Joined: Tue Nov 04, 2014 11:04 am

Re: syrthes refuses to run due to not-installed MPI

Post by kathi » Wed Feb 08, 2017 1:14 pm

and here the syrthes input file "3disks.syd" . .

( I had to rename it from "3disks.syd" to "3disks_syd.ini" because the file uploader of this forum told me that the file extension .syd is not allowed)

kathi
3disks_syd.ini
(3.04 KiB) Downloaded 111 times
best regards

kathi

Yvan Fournier
Posts: 2720
Joined: Mon Feb 20, 2012 3:25 pm

Re: syrthes refuses to run due to not-installed MPI

Post by Yvan Fournier » Sun Feb 12, 2017 7:16 pm

Hello,

The communication between Code_Saturne and Syrthes when coupling the two codes uses MPI. So even if you only do non-parallel runs of each code, you need MPI.

Regards,

Yvan

Post Reply